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USER GUIDE AND SPEGIFICATIONS

NI USB-6008/6009
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ni.com/manuals

This user guide describes how to use the National Instruments
USB-6008/6009 data acquisition (DAQ) devices and lists specifications.

Introduction

The NI USB-6008/6009 provides connection to eight analog input (AT)
channels, two analog output (AO) channels, 12 digital input/output (DIO)

channels, and a 32-bit counter with a Full-Speed USB interface.

Note This manual revision updates naming conventions to reflect the conventions used in
NI-DAQmx. Table 1 notes the correlation between the old and updated names,

Table 1. Digitat Qutput Driver Type Naming Gonventions
NI-DAQmx Terminology

Hardware Functioriality
Open-drain Open collector
Push-pull Active drive
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Dimensions

Figure 3 illustrates the dimensions of the NI USB-6008/6009 device.
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Figure 3. NI USB-6008/6003 in Millimeters {Inches)

Safety Guidelines

A Caution  Operate the NI USB-6008/6009 only as described in these operating instructions.

The following section contains important safety information that you must
follow when installing and using the NI USB-6008/6009,

/I Gaution Do not operate the NI USB-6008/6009 in a manner not specified in this
document. Misuse of the device can result in a hazard. You can compromise the safety
protection built into the device if the device is damaged in any way. If the device is
damaged, contact National Instruments for repair.

A Gaution Do not substitute parts or modify the device except as described in this document.
Use the device only with the chassis, modules, accessories, and cables specified in the
installation instructions. You must have all covers and filler panels installed during
operation of the device. '
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*  Measuremént Category II is for measurements performed on circuits
diréétly connected to the electrical distribution system. This category
réfers to Jocal-level electrical distribution, such as that provided by a
standard wall outlet (for example, 115 V for U.S. or 230 V for Burope).
Examples of Measurement Category II are measurements performed
on household appliances, portable tools, and similar E Series devices.

*  Measurement Category IIL is for measurements performed in the
building installation at the distribution level. This category refers to
measurements on hard-wired equipment such as equipment in fixed
installations, disteibution boards, and circuit breakers. Other examples
are wiring, inclnding cables, bus-bars, junction boxes, switches,
socket-outlets in the fixed installation, and stationary motors with
permanent connections to fixed installations.

*  Measurement Category IV is for measurements performed at the
primary electrical supply installation (<1,000 V). Examples include
electricity meters and measurements on primary overcurrent
protection devices and on ripple control units,

Related Documentation

Each application software package and driver includes information about
writing applications for taking measurements and controlling measurement
devices. The following references to documents assume you have
NI-DAQmx 8.7 or later, and where applicable, version 7.1 or later of the
NI application software.

NI-DAQmx for Windows

The DAQ Getting Started Guide describes how to install your NI-DAQmx
for Windows software, how to install your NI-DAQmx-supported DAQ
device, and how to confirmn that your device is operating properly. Select
Start»All Programs»National Instruments»NI-DAQ»DAQ Getting
Started Guide. ) :

The NI-DAQ Readme lists which devices are supported by this version of
NI-DAQ. Select Start»All Programs»National Instruments»NI-DA Q»
NI-DAQ Readme.

The NI-DAQGmx Help contains general information about measurement
concepts, key NI-DAQmx concepts, and common applications that are
applicable to all programming environments. Select Start»All Programs»
National Instruments»NI-DA Q»NI-DAQmx Help.

@ Note For information about non-Windows operating system support, refer {o ni . com/
info and enter BaseGSGML.
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can create channels and tasks, and write your own applications in your
ADE using the NI-DAQmx APL

For help with NI-DAQmx methods and properties, refer to the NI-DAQmx
NET Class Library or the NI-DAQmx Visual C++ Class Library included
in the NI Measurement Studio Help. For general help with programming in
Measurement Studio, refer to the NI Measurement Studio Help, which is
integrated with the Microsoft Visual Studio .NET help. To view this

help file in Visual Studio. NET, select Measurement Studio»

NI Measurement Studio Help.

To create an application in Visual C++, Visual C#, or Visnal Basic NET,
follow these general steps:

L. In Visual Studio .NET, select File»New»Project to launch the New
Project dialog box.

2. Find the Measurement Studio folder for the language you warit to
create a program in,

3. Choose a project type. You add DAQ tasks as a part of this step.

ANSI C without NI Application Software

The NI-DAQmx Help contains API overviews and general information
about measurement concepts. Setect Start»All Programs»National
Instruments»NI-DAQ»NI-DAQmx Help,

The NI-DAQmx C Reference Help describes the NI-DAQmx Library
functions, which you can use with National Instroments data acquisition
devices to develop instrumentation, acquisition, and control applications. -
Select Start»All Programs»National Instruments»NI-DA Q»
NI-DAQmx C Reference Help,

.NET Languages without NI Application Software

With the Microsoft NET Framework version 1.1 or later, you can use
NE-DAQmx to create applications using Visual C# and Visual Basic
NET withont Measurement Studio. You need Microsoft Visual Studio
NET 2003 or Microsoft Visual Studio 2005 for the API documentation
to be installed.

The installed documentation contains the NI-DAQmx API overview,
measurement tasks and concepts, and function reference. This help is
integrated into the Visuat Studio .NET documentation. To view the
NI-DAQmx .NET documentation, go to Start»All ProgramssNational
Instruments»NI-DAQ»NI-DAQmx .NET Reference Help. Expand
NI Measurement-Studio Help»NI Measurement Studio NET Class
Library»Reference io view the function reference. Expand

NI Measurement Studio Help»NI Measurement Studio .NET Class
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@ Note All NI-DAQmx Base documentation for Mac OS X is instalied at
/Applications/National Instruments/NI-DAQmx Base/documentation.

Training Courses

If you need more help getting started developing an application with
NI products, NI offers training courses. To enroll in a course or obtain
a detailed course outline, refer to ni . com/training.

Technicél Support on the Web

For additional support, refer to ni . com/support or zone.ni, com.

Installing the Software

Software support for the NI USB-6008/6009 for Windows Vista/XP/2000
is provided by NI-DAQmx. The DAQ Getting Started Guide, which you
can downioad at ni . com/manuals, offers NI-DAQinx users step-by-slep
instructions for installing software and hardware, configuring channels and
tasks, and getting started developing an application.

@ Mote For information about non-Windows operating system support, refer to ni.com/
info and enfer BageGSGHL.

Installing Other Software

If you are using other software, refer to the installation instructions that
accompany your software.

Example Programs

The NI-DAQmx CD contains example prograrms that you can use fo get
started programming with the NI USB-6008/6009. Refer to the N-DAQOmx
for USB Devices Getting Started Guide that shipped with your device, and
is also accessible from Start»All ProgramssNational Instruments»
NI-DAQ, for more information. '

The NI-DAQmx Base software ships with example programs you can use
to get staited programming with the NI USB-6008/6009. Refer to the
NI-DAQmx Base Getting Started Guide that shipped with your device, and
is also accessible from StartsAll Programs»National Instruments»
NI-DAQmx Base»Examples, for more information.

@ Note For information abount non-Windows operating system support, refer to
ni.com/info and enter BaseGSGML.
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2. Figure 5 illustrate:s the signal labels that ship in the NI TUSB-6008/6009
kit. You can apply the signal labels to the screw terminal blocks for
easy signal identification. '

[GNO| +AD- GRD) +AH- IGND| +AR- [GND| +AI3- [GND]A00| AD1IGND, o
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1 Terminal Number Labels {(Use Both Togather) 3 Differential Signal Name Label (Use Either)
2 Digital I/O Label 4 Single-Ended Signal Name Label {Use Either)

Figure 5. NI USB-6008/6009 Signal Labels

3. Refer to Table 4 and Figures 5 and 6 for signal label orientation and
affix the provided signal labels to the sciew terminal blocks. Until the
signal labels are applied, you ean insert the screw terminal blocks into
either of the combicon jacks.

1 Ovarlay Label with Pin Orientation Guides 3 Signal Labels
2 Combicon Jack 4 USB Cable

Figure 6. Signal Labsl Applicatior Diagram
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Table 4 lists the analog terminal assignments, and Table 5 lists the digital
terminal assignments.

Table 4. Analeg Terminal Assignments

_ Signal, ) Signal,
Module _ Terminai Single-Ended Mode Differential Mode

1 GND GND

( 1. 2 | INCO Al O+
R 3 Al 4 AT O-
= | 4 GND GND
% - 5 ALl Al1+
% : ) 6 ALS All-
e 7 GND GND
% : 8 Al2 AT 2+
% - 9 AT6 Al2-
ca)s 10 GND GND
% % 11 AI3 Al 3+
% ; ) 12 | A17 AI3-
% g i3 GND GND
= || 14 AOO A0 0
et 15 | a0t AO1
. 16 GND GND
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| Sign'al Descriptions

Table 6 describes the signals available on the /O connectors.

Table 6. Signal Descriptions

_Signal Name

Reference Direction Description

GND

— ' — Ground—The reference point for the
single-ended AT measuwrements, bias
current return point for differential mode
measurements, AQ voltages, digital
signals at the IO connector, +5 YDC
supply, and the +2.5 VDC reference.

AL <0.7>

Varies Input Analog Input Channels 0 to 7—For
single-ended measurements, each signal is
an analog input voltage channel. For
differential measwrements, AI Q0 and Al 4
are the positive and negative inputs of
differential analog input channel 0.

The following signal pairs also form
differential input channels:

<Al 1, Al 5>, <Al 2, Al 6>, and

<Al3, Al 7>,

ACQ

GND Cutput , Analog Channel OIOutput—Supplies the
wvoltage output of AO channel 0,

AO1

GND Output Analog Channel 1 Quiput—Supplies the
voltage output of AO channel 1,

P1.<0..3>
P0.<0..7>

GND Input or Digital /O Signals—You can
Output individoally configure each signal as an
input or output.

425V

GND Ountput +2.5 V External Reference—Provides a
' reference for wrap-back testing.

5V

GND Output +5 V Power Source—Provides +5 V
power up to 200 mA.

PFIO

GND Input PFI 0—This pin is configurable as eithera
| digital trigger or an event counter input.

© National Instruments Corporation 15 Nt USB-8008/6089 User Guide and Specifications




Al FIFO

The NI USB-6008/6009 can perform both single and multiple A/D
conversions of a fixed or infinite number of samples. A first-in-first-oni
(FIFO) buffer holds data during Al acquisitions to ensure that no data
is lost. .

Analog Input Modes

You can configure the Al channels on the NI USB-G008/6009 to take
single-ended or differential measurements. Refer to Table 6 for more
information about I/O connections for single-ended or differentiai
measurements, )

Connecting Differential Voltage Signals

For differential signals, connect the positive lead of the signal to the
Al+ terminal, and the negative lead to the Al- terminal. -

Al i

Q) H

¥ ; :

Voitage C) ! NI USB-6008/6008 }
Source \__ : ;
A= .:

Figure 8. Connecting a Differential Voltage Signal

The differential input mode can measure 20 V signals in the £20 V range.
However, the maximum voltage on any one pin is £10 V with respect to
GND. For example, if AT11s 410 V and AI 5is 10 V, then the
measurement returned from the device is 420V,
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Digital Trigger

Analog Output

oy i

— ;

Voltage CL) ! NI USB-6008/6009 |
Source\ _ : i
enp:

Figure 11. Connecting a Referenced Single-Ended Voltage Signal

‘When an Al task is defined, you can configure PRI O as a digital trigger
input. When the digital trigger is enabled, the Al task waits for a rising or
falling edge on PFI O before starting the acquisition. To use aifStart Trigger
with a digital source, specify PFI 0 as the source and select rising or falling
edge.

The NI USB-6008/6009 has two independent AQ channels that can
generate outputs from 0-5 V. All updates of AQ lines are software-timed.

Analog Output Circuitry

Figure 12 illustrates the analog output circuitry for the NI USB-6008/6009.

+5V
C

REF(+) REF(-)
12-Bit

AQ
DAC ‘

Flgure 12. Analog Output Gircuitry
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Digital I/0 Circuitry
Figure 14 shows P0.<0..7> connecied to example signals configured as
digital inputs and digital outputs. You can configure P1.<0..3> similarly.

5V

@/"/V'

LED /E/'

é AV O PO.O
LED é o PO
—K}——vw» o PO.2
[ P03

%
Y

P0.4

5y TTL Signal  |{© PO.5
o PO.6
P A O PO.7

!
Switch\i

Y

2 9%

YO Connector T

P0.0 configured as an open colfector digital output driving an LED

F0.2 configured as an active drive digital output driving an LED

P04 configured as a digital input receiving a TTL signal from a gated invertor
P0.7 configured as a digital input receiving a ¢ V or 5 V slgnal from a switch

B0 N -

Figure 14. Example of Connecting a Load

Caution  Exceeding the maximum input voltage ratings or maximum outpu ratings, which
are listed in the Specifications section, can damage the device and the compnter, Nationat
Instruments is not liable for any damage resulting from such signal connections.

Source/Sink Information

The default configuration of the NI UUSB-6008/6009 DIO ports is open
collector, allowing 5 V operation, with an onboard 4.7 kO pull-up resistor.
An external user-provided pull-up resistor can be added to increase the
source current drive up {o a 8.5 mA limit per line as shown in Figure 15,

The NI USB-6009 ports can also be configured as active drive using the
NE-DAQmx API, allowing 3.3 V operation with a source/sink current Hmit -
of £8.5 mA. Refer to the NI-DAQmx Help for more information about how
to set the DIO configuration.
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1/0 Protection

Power-On States

Static DIO

Event Counter

To protect the NI USB-6008/6009 against overvoltage, undervoliage, and
overcurrent conditions, as well as ESD events, you should avoid these fault
conditions by using the following guidelines:

+ If you configure a DIO line as an cutput, do not connect it to any
external signal source, ground signal, or power supply.

» If you configure a DIO line as an output, understand the cmrent
requirements of the load connected to these signals. Do not exceed
the specified current output Himits of the DAQ device.

National Instruments has several signal conditioning solutions for
digital applications requiring high current drive, ' ’

+ If you configure a DIO line as an input, do not drive the line with
voltages ountside of its normal operating range. The DIO lines have
a smaller operating range than the Al signals.

¢ Treat the DAQ device as you wonld treat any static sensitive device.
Always property ground yourself and the equipment when handling
the DAQ device or connecting to it,

Al system startup and reset, the hardware sets all DIO Jines to
high-impedance inputs. The DAQ device does not drive the signal high
or low. Each line has a weak pull-up resistor connected to it.

Each of the NI USB-6008/6009 DIO lines can be used as a static DI or
DO line. You can use static DIO lines to monitor or control digital signals.
All samples of static DI lines and updates of DO lines are sofiware-timed.

You can configure PFI 0 as a source for a gated invertor counter input edge
count task. In this mode, falling-edge events are counted using a 32-bit
counter. For more information ahout event timing requirements, refer to the
Specifications section,
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TIMING ACCUTACY ovvrvirerererrrecrrenereseeraesesns 100 ppm of actual sample rate

Input range
Single-ended ..iivecein e +10V
Differential........ccoovecrrcvnrnnnn 220 VL 210V, 25V, 24 V,
2S5V, 22V, 2125V, 1V
Working voltage....coeveeeneeccvinecnnancnn, 10V
Input impedance........cvevrneneesivererenennn 144 k€3
Overvoltage protection...... eeeeenoneeseeens +35
VTrigger SOULCE Lovcecaaerranrrerrrnrvens o Software or external digital
trigger
System noise?
Single-ended
#10 V 5ange ..ovveeormeveereerienninns 5mVrms -
Differential
$20 V range evevesieevenenns 5 mVims
S IR -1 1 O 0.5 mVrms
Absolute accuracy at full scale, single-ended
Range Typical at 25 °C (mV) Maximum over Temperature {mV)
+10 14.7 138

Absolute accuracy at full scale, differential®

Range Typical at 25 °C (mV) Maximum over Temperature (inV)
20 - 147 138
+10 . 7.73 84.8
+5 4.28 584
44 3.59 53.1
+2.5 2.56 , 45.1

I +20 V means that AT+ — (AT-)} <= 20 V. However, AT+ and AT- must both be within £10 V of GND. Refer to the Connecting
Differential Voltage Signals for more information.

? ‘System noise measured at maximum sample rate.
* Input voltages may not exceed the working voltage range.
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Compatibiity ..ooeeereececevererrrer, A TTL, LVTTL, CMOS

Absolute maximum voltage range ......... —-0.5t0 5.8 V with respect to GND
Pull-up resistor ..o 47 kQ 10 5V
Power-on state......ooccvveeereiienennn S Input

Digital logic levels

Level Min Max Units
Input low voltage -0.3 0.8 v
Input high voltage 2.0 58 v
Input leakage current — 50 A
Output low voltage (= 8.5 mA) : — 08 v
Gutput high voltage .
Active drive (push-pull), I = -8.5 mA 2.0 3.5 v
Open collector {open-drain), I = —0.6 mA, nominal 2.0 5.0 Vv
Open collector {open-drain), I =—8.5 mA, with exiernal 2.0 — v
pull-up resistor '
Exiernal Voltage
+5 V output (200 mA maximom) .......... +5 V typical, +4.85 V minimum.
+2.5 V output (1 mA maximum) ........... +2.5V typicél
+2.5 V ACCHTACY vovverierrecrireciesresiereeeiennes {(1.25% max
Reference temperature drifi .......coovieana. 50 ppm/°C max
Counter
Number of Counters. ......ooveevnnrerreerneens 1
ReSOMEON v 32 DS
Counter measurements .......c.cvervverrveerenes Edge counting {falling-edge}
Counter direCtion......ovnvervcrcimnnenieneninens Count up
PUILUP TESISOL vervrrrrovrrereresserrerersanne 47 KQ 10 5V
Maximum input frequency.......ooeeeeeenee. 5 MHzZ
Minimum high pulse width........ccoeevce. 100 ns
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Safely

If you need to clean the module, wipe it with a dry towel,

Safety Voltages

Connect only voltages that are within these limits.

Channel-to-GND ........oveevvevvnrvrerninneen. £30 V max,
Measurement Category

Measurement Category I is for measurements performed on circuits not
directly connected to the electrical distribution system referred to as
MAINS voltage, MAINS is a hazardous live electrical supply system that
powers equipment. This category is for measurements of voltages from
specially protected secondary cirenits. Such voltage measurements include
signal levels, special equipment, limited-energy parts of equipment,
circuits powered by regulated low-voltage sources, and elecironics,

A Gaution Do not use this module for connection to signals or for measurements within
Measurement Categories IT, I, or IV.

Safety Standards

This product is designed to meet the requirements of the following
standards of safety for electrical equipment for measurement, control,
and laboratory use:

+ IEC61010-1, EN 61010-1 ~
+ UL 61010-1, CSA 61010-1

@ Note For UL and other safety certifications, refer to the product label or visit
ni.com/certification, search by model number or product line, and click the
appropriate link in the Certification colummn. '

Hazardous Locations

The NI USB-6008/6009 device is not certified for use in hazardous
locations.
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Environmental Management

I3

National Instruments is committed to designing and mannfacturing
products in an environmentally responsible manner. NI recognizes that
eliminating certain hazardous substances from our products is beneficial
not only to the environment but also to NI customérs.

For additional environmental information, refer to the NI and the

Enyironment Web page at ni.. com/enviromuent. This page contains the
environmental regulations and directives with which NI complies, as well
as other environmental jnformation not inclunded in this document.

Waste Electrical and Eiectromc Equipment (WEEE)

EU Customers At the end of their life cycle, all products must be sent to a WEEE recycling
center. For more information about WEEE recycling centers and National Instrumenis
WEEE initiatives, visit ni . com/environment /weee . htm.

BT EEERSREHEEME (FE ROHS)

REEA  National Instruments -4 b7 B 7= 8o B E LT S84 (ROHS).
KT Natlonal Instrurments =B RoHS & HHEER, #BF ni. com/environment/rohs_china.
(For Information about China RoHS compliancs, go to ni. com/environment /rohs_china.)

Where to Go for Support

The National Instruments Web site is your complete resource for technical
support. At ni.com/support you have access to everything from
troubleshooting and application development self-help resources to email
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at

11500 North Mopac Expressway, Austin, Texas, 78759-3504.

National Instruments also has offices located around the world to help
address your support needs. For telephone support in the United States,
create your service request at ni . com/suppoxrt and follow the calling
instructions or dial 512 795 8248. For telephone support outside the United
States, contact your local branch office:

Aunstralia 1800 300 800, Austria 43 662 457990-0,

Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599,

Canada 800 433 3488, China 86 21 5050 9800,

Czech Republic 420 224 235 774, Denmark 45 45 7626 00,

Finland 358 (0) 9 725 72511, France 01 57 66 24 24,

Germany 49 89 7413130, Indiz 91 80 41190000, Isracl 972 3 6393737,
Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400,
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